转换基于Maven的Web应用程序支持Eclipse IDE

<faceted-project><fixed facet="jst.java"/><fixed facet="jst.web"/><installed facet="jst.web"version="2.4"/><installed facet="jst.java"version="1.4"/></faceted-project>
注意
使用JDK1.4 和 Maven2.X生成的 Web应用程序(见上文),这是相当过时,需要将其升级到最新的JDK版本。

File : org.eclipse.wst.common.component

<project-modules id="moduleCoreId"project-version="2.0"><wb-module deploy-name="mkyongweb-core"><property name="context-root"value="mkyongweb-core"/><wb-resource deploy-path="/"source-path="src/main/webapp"/><property name="java-output-path"value="/target/classes"/><wb-resource deploy-path="/WEB-INF/classes"source-path="src/main/resources"/></wb-module></project-modules>

3. 导入到Eclipse IDE

现在,我们已经拥有了一个 Eclipse 的 Web应用程序需要配置和文件,那么,就可以开始导入基于Maven构建Web应用程序到Eclipse IDE中去了。

步骤:
在Eclipse IDE 的菜单栏, File -> Import… -> General -> Existing Projects into Workspace -> 选择根目录(选择项目文件夹中)-> 完成。

Convert Maven based web application to support Eclipse IDE

完事大吉!

参考

  1. http://maven.apache.org/plugins/maven-eclipse-plugin/eclipse-mojo.html
  2. http://maven.apache.org/plugins/maven-eclipse-plugin/wtp.html
  3. http://wiki.eclipse.org/WTP_FAQ#What_version_of_Eclipse_does_WTP_work_with.3F
  4. Unsupported WTP version: 1.5. This plugin currently supports only the following versions: 1.0 R7