忙于采集的蜜蜂,无暇在人前高谈阔论 [登录·注册]

吕滔博客

首页 开发 运维 工具 摄影

Homebrew让mac系统中像centos的yum一样的方便快捷的安装软件

xcode&mac memory 发布于April 14, 2014 标签: PHP, mac

mac 系统常用的软件安装工具就是 homebrew, 其最常用的命令如下:

安装(需要 Ruby):

ruby -e "$(curl -fsSL https://raw.github.com/Homebrew/homebrew/Go/install)"

搜索:brew search MySQL

查询:brew info mysql 主要看具体的信息,比如目前的版本,依赖,安装后注意事项等

更新:brew update 这会更新 Homebrew 自己,并且使得接下来的两个操作有意义——

检查过时(是否有新版本):brew outdated 这回列出所有安装的软件里可以升级的那些

升级:brew upgrade 升级所有可以升级的软件们

清理:brew cleanup 清理不需要的版本极其安装包缓存

常用的就这些。一般来说如果你追求新版本(不升级不舒服斯基),那么你最常用的操作序列就是这样:

brew update          # 更新 Homebrew 的信息
brew outdated        # 看一下哪些软件可以升级
brew upgrade <xxx>   # 如果不是所有的都要升级,那就这样升级指定的

brew upgrade; brew cleanup    # 如果都要升级,直接升级完然后清理干净

PHP常用

大版本可以用brew list来查,如果是小版本的话只能去/usr/local/Cellar/php71看了。这个时候使用php-version可以更方便一点。

安装php-version

php-version是一个帮助管理从brew安装的php版本切换的工具。

安装非常简单

brew install php-version

然后执行

source $(brew --prefix php-version)/php-version.sh && php-version 5

使用php-version

直接执行

php-version

就可以看到现有的版本,比如我自己的

$ php-version
  5.5.15
* 5.5.16
  5.5.17

然后使用以下命令切换即可

php-version 5.5.15

再看php的版本,已经切换好了。

相关推荐

添加新评论

网站状态

  • 栏目分类:49个
  • 发布文章:1534篇
  • 用户评论:751条
  • 开博至今:4128天

正则速查

[abc] 匹配中括号中的单个字符,如a或b或c
[^abc] 匹配除了a、b、c等字符的其他单个字符
[a-z] 匹配一个字符范围,如a到z
[a-zA-Z] 匹配一个字符范围,如a-z 或 A-Z
^ 匹配行的开始
$ 匹配行的结束
\A 匹配一个字符串的开始
\z 匹配一个字符串的结束
. 匹配任意单个字符
\s 匹配空白字符,如空格,TAB
\S 匹配非空白字符
\d 匹配一个数字
\D 匹配非数字
\w 匹配一个字母
\W 匹配非字母
\b 匹配字符边界
(...) 引用所有括号中的内容
(a|b) a或者b
a? 零个或1个a
a* 零个或多个a
a+ 1个或多个a
a{3} 3次重复的a
a{3,} 3次或3次以上重复的a
a{3,6} 3到6次重复的a

修正符

/g 查找所有可能的匹配
/i 不区分大小写
/m 多行匹配
/s 单行匹配
/x 忽略空白模式
/e 可执行模式,PHP专有
/A 强制从目标字符串开头匹配
/D 使用$限制结尾字符,则不允许结尾有换行
/U 只匹配最近的一个字符串;不重复匹配

最新回复

  • hyvm.net: 好文章,点赞
  • 新闻头条: 文章不错非常喜欢
  • 志志: 折腾了半天 感谢大神
  • Smithk464: Hey very nice blog!! Man .. Exce...
  • memory: 我已投奔phpstrom.哈哈
  • 逆风飘扬: 原来是这样!!!!!!!用惯了VS的来用zend studio没...
  • NS: 请问我这么写之后抛出了一个 javax.crypto.BadPa...
  • memory: 有内部使用的,开源的过段时间放个出来。
  • 小小: 博主 ,可有写好的
  • 111: 我看不懂唉,好多内容
  • memory: 咧,难道我手误了,回头看下官方文档去...
  • 阿东: 进入镜像的 后面 /bin/bash 是错的 你应该用的是/b...
  • memory: 帝国的安全性来说,比phpcms和dede要好的多啦.
  • 西点师培训班: 现在帝国用的少了,开源的不太会改,老被黑
  • yiyiyizoe: 谢谢~
  • memory: 不好意思呀,这个也是13年的时候,安装过淘宝的这个开源系统,做的...
  • yiyiyizoe: 实在抱歉,如果可以回答的话,只需要看这个问题:ldb支持批量导入...